首页 > 其他 > 详细

Wu XING

时间:2014-03-24 23:32:44      阅读:649      评论:0      收藏:0      [点我收藏+]


Description

Introduction

The Wu Xing, or the Five Movements, Five Phases or Five Steps/Stages, are chiefly an ancient mnemonic device, in many traditional Chinese fields.

The doctrine of five phases describes two cycles, a generating or creation cycle, also known as "mother-son", and an overcoming or destruction cycle, also known as "grandfather-nephew", of interactions between the phases.

Generating:

  • Wood feeds Fire;
  • Fire creates Earth (ash);
  • Earth bears Metal;
  • Metal carries Water (as in a bucket or tap, or water condenses on metal);
  • Water nourishes Wood.

Overcoming:

  • Wood parts Earth (such as roots) (or Trees can prevent soil erosion );
  • Earth absorbs (or muddies) Water (or Earth dam control the water);
  • Water quenches Fire;
  • Fire melts Metal;
  • Metal chops Wood.

bubuko.com,布布扣


With the two types of interactions in the above graph, any two nodes are connected by an edge.

Problem

In a graph with N nodes, to ensure that any two nodes are connected by at least one edge, how many types of interactions are required at least? Here a type of interaction should have the following properties:

  • It can be represented as a set of directed edges in the graph.
  • For each type of interaction, there should be one and only one edge starting at each node.
  • For each type of interaction, there should be one and only one edge ending at each node.
  • The interactions are made up of cycles, i.e. starting from an arbitrary node and following the edges with the same type of interaction, you can always reach the starting node after several steps.

Input

For each test case, there‘s a line with an integer N (3 <= N < 1,000,000), the number of nodes in the graph.

N = 0 indicates the end of input.

Output

For each test case, output a line with the number of interactions that are required at least.

Sample Input

5
0


Sample Output

2


n个点两两有关系可构成n/2个环

#include <iostream>
using namespace std;
int main()
{
	int n;
	while(cin>>n&&n)
	{
		cout<<n/2<<endl;
	}
	return 0;
}



Wu XING,布布扣,bubuko.com

Wu XING

原文:http://blog.csdn.net/a120705230/article/details/21989467

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!