首页 > 其他 > 详细

HDU 1856 More is better

时间:2014-04-24 15:12:13      阅读:608      评论:0      收藏:0      [点我收藏+]

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
4 2

题目大意: 给出若干对朋友,朋友的朋友也是朋友,求出哪一个朋友圈的人数最多。

思路: 并查集。另开一个数组保存每个朋友圈的人数保存在祖先里,初始化为为1,(因为一开始每个集合只有一个人),当两个集合合并的时候把一个朋友圈祖先的人数加到另一个祖先人数上。找出最大值即可。


#include<stdio.h>
int n,_max,fa[10000005],num[10000005];
int Find(int x)
{
    return x==fa[x]?x:fa[x]=Find(fa[x]);
}
int main()
{
    while(~scanf("%d",&n)) {
        for(int i=1;i<=10000005;i++)
            fa[i]=i,num[i]=1;
        _max=1;
        for(int i=1;i<=n;i++) {
            int x,y,fx,fy;
            scanf("%d%d",&x,&y);
            fx=Find(x),fy=Find(y);
            if(fx != fy) {
                num[fy]+=num[fx];
                fa[fx]=fy;
                if(num[fy]>_max) _max=num[fy];
            }
        }
        printf("%d\n",_max);
    }
    return 0;
}



HDU 1856 More is better,布布扣,bubuko.com

HDU 1856 More is better

原文:http://blog.csdn.net/u013923947/article/details/24364913

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!