首页 > 其他 > 详细

hdu 1071 the area 用积分求面积

时间:2014-03-22 01:20:06      阅读:520      评论:0      收藏:0      [点我收藏+]

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1071

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7011    Accepted Submission(s): 4934


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

bubuko.com,布布扣
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

 

Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 
分析:  计算抛物线和直线方程, 代入求积分即可。
代码如下:
bubuko.com,布布扣
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <vector>
using namespace std;
typedef long long ll;
double x1,y11,k,b,a;
// 积分
double f(double x)    // 不定积分值
{
    return a*(x-x1)*(x-x1)*(x-x1)/3.0 - k/2*x*x+(y11-b)*x;
}


int main() {
    double x2,y2,x3,y3;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>x1>>y11>>x2>>y2>>x3>>y3;
        a=(y3-y11)/((x3-x1)*(x3-x1));
        k=(y3-y2)/(x3-x2);
        b=y3-k*x3;
        printf("%.2f\n",f(x3)-f(x2));  // 定积分代入上下限
    }

    return 0;
}
bubuko.com,布布扣

 

hdu 1071 the area 用积分求面积,布布扣,bubuko.com

hdu 1071 the area 用积分求面积

原文:http://www.cnblogs.com/zn505119020/p/3616776.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!