首页 > 其他 > 详细

【HDU 1005】Number Sequence —— 找周期

时间:2015-04-27 18:26:08      阅读:90      评论:0      收藏:0      [点我收藏+]

原题链接


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 122213    Accepted Submission(s): 29653


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5




解题报告:

一开始做这题就是想暴力求解,所以如期的TLE了。然后换个思路,直接算出了通项公式,但是通项公式有两项都是带根号的,最后不能很好的转换为int,放弃!再接着,瞥了下discuss里面的讨论,得到的关键字是周期,其实也很容易想到,毕竟是mod 7,很快就应该有周期,所以只需要找到周期就好。注意!!!但是由于f(1)=f(2)=1是初始项,并不一定满足通项的结构,所以应该从f(3)开始匹配找周期!更详细的解释请移步:[ACM_HDU_1005]Number Sequence

当然,这题还有另外的解法,详见 【HDU1005】Number Sequence(矩阵乘法)



#include <iostream>
using namespace std;
int a,b,n;
int A[100];
int main()
{
    while(cin>>a>>b>>n){
        if(!a && !b && !n) break;
        if(n==1 || n==2) cout<<1<<endl;
        else{
            A[1]=A[2]=1;int cyc=n;
            for(int i=3;i<=100;++i){
                A[i]=(a*A[i-1]+b*A[i-2])%7;
                if(i>5 &&  A[i]==A[4] && A[i-1]==A[3]){cyc=i-4;break;}
            }

            //输出
            cout<<A[(n-3)%cyc+3]<<endl;
        }
    }
    return 0;
}


【HDU 1005】Number Sequence —— 找周期

原文:http://blog.csdn.net/treasuresss/article/details/45313297

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!