首页 > 其他 > 详细

The area

时间:2015-02-11 12:48:47      阅读:255      评论:0      收藏:0      [点我收藏+]

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8108    Accepted Submission(s): 5694


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

技术分享

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 

Author
Ignatius.L
 
思路:这属于数学范畴。。定积分求面积,然后减去梯形面积。。还是要求定积分,首先要知道抛物线的方程。
技术分享
#include<iostream>  //1071
#include<stdio.h>
using namespace std;
int main()
{
   int T;
   double x1,y1,x2,y2,x3,y3,a,s;
   cin>>T;
   while(T--)
   {
      cin>>x1>>y1>>x2>>y2>>x3>>y3;
      a=(y2-y1)/((x2-x1)*(x2-x1));
      s=a*(x3*x3*x3-x2*x2*x2)/3+(x2*x2-x3*x3)*a*x1+(x3-x2)*(a*x1*x1+y1);
      s=s-(y2+y3)*(x3-x2)/2;
      printf("%.2lf\n",s);
   }
    return 0;
}

The area

原文:http://blog.csdn.net/zuguodexiaoguoabc/article/details/43731237

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!