首页 > 数据库技术 > 详细

Tomcat - java.lang.UnsupportedClassVersionError:Unsupported major.minor version 51.0 (unable to load class com.microsoft.sqlserver.jdbc.SQLS

时间:2015-01-30 14:34:36      阅读:4005      评论:0      收藏:0      [点我收藏+]

标签:des   class   style   com   log   使用   java   http   si   

今天使用Tomcat连接sql Server 2008 enterprise的时候,报错:

HTTP Status 500 - Servlet execution threw an exception

type Exception report

message Servlet execution threw an exception

description The server encountered an internal error that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet execution threw an exception
	spt.servlet.filter.EncodingFilter.doFilter(EncodingFilter.java:24)

root cause

java.lang.UnsupportedClassVersionError: com/microsoft/sqlserver/jdbc/SQLServerDriver : Unsupported major.minor version 51.0 (unable to load class com.microsoft.sqlserver.jdbc.SQLServerDriver)
	org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2961)
	org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1210)
	org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1690)
	org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1571)
	java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
	java.lang.Class.forName0(Native Method)
	java.lang.Class.forName(Class.java:169)
	spt.server.jdbc.db.BasicDB.getConnection(BasicDB.java:260)
	spt.server.jdbc.db.BasicDB.getPreparedStatement(BasicDB.java:268)
	spt.server.jdbc.db.BasicDB.getAQIDayByCityCodeAndDate(BasicDB.java:136)
	spt.service.AQIDayService.getAQIDay(AQIDayService.java:33)
	spt.servlet.JsonServlet.doPost(JsonServlet.java:34)
	spt.servlet.JsonServlet.doGet(JsonServlet.java:53)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:620)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	spt.servlet.filter.EncodingFilter.doFilter(EncodingFilter.java:24)

note The full stack trace of the root cause is available in the Apache Tomcat/7.0.57 logs.
Apache Tomcat/7.0.57

 JDK的版本号对应:

J2SE 7 = 51 (0x33 hex),

J2SE 6.0 = 50 (0x32 hex),

J2SE 5.0 = 49 (0x31 hex),

JDK 1.4 = 48 (0x30 hex),

JDK 1.3 = 47 (0x2F hex),

JDK 1.2 = 46 (0x2E hex),

JDK 1.1 = 45 (0x2D hex).

由此可知,上述错误是由于jTDS需要jdk7,而你使用的JDK版本不是jdk7。

ref: http://shalousoft.com/go_newsForum.action?op=d3a91dac-6b7c-11e3-8e31-5254001578d1

Tomcat - java.lang.UnsupportedClassVersionError:Unsupported major.minor version 51.0 (unable to load class com.microsoft.sqlserver.jdbc.SQLS

标签:des   class   style   com   log   使用   java   http   si   

原文:http://www.cnblogs.com/listened/p/4261666.html

(1)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号