首页 > 其他 > 详细

CSU 1354 Distinct Subsequences 求不相同子序列的和 dp

时间:2015-01-24 20:06:26      阅读:310      评论:0      收藏:0      [点我收藏+]

题目链接:点击打开链接


Description

    Give a positive number, count the sum of the distinct subsequence of it, moreover, any subsequence should not contain leading zeroes except it is zero.
    For example, if the number is 1022, the answer is 1 + 0 + 2 + 10 + 12 + 22 + 102 + 122 + 1022 = 1293.

Input

    The first line has an integer T, means there are T test cases.
    For each test case, there is only one line with a positive number, the number of the digits of it is in range [1, 105].
    The size of the input file will not exceed 5MB.

Output

    For each test case, print the desired answer in one line. Because the answer may be very large, you just need to print the remainder of it divided by 1000000007 instead.

Sample Input

3
7
1022
1000000001

Sample Output

7
1293
222222223




思路:

dp[i]表示以数字i结尾的子序列的和,num[i]表示以i结尾的子序列的个数

import java.io.PrintWriter;
import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Iterator;
import java.util.LinkedList;
import java.util.PriorityQueue;
import java.util.Scanner;
import java.util.TreeSet;
import java.util.Queue;

public class Main {
	static int mod = 1000000007;
	static int N = 100010;
	long[] dp = new long[10], num = new long[10];
	String s;
	void work() {
		int T = cin.nextInt();
		while(T-- > 0) {
			s = cin.next();
			int len = s.length();
			for(int i = 0; i < 10; i++)dp[i] = num[i] = 0;
			for(int i = 0; i < len; i++)
			{
				int x = s.charAt(i)-'0';
				long sum = 0, n = 0;
				for(int j = 0; j < 10; j++)
				{
					sum += dp[j];
					n += num[j];
				}
				if(x>0)n++;
				dp[x] = sum*10%mod + n*x%mod;
				num[x] = n%mod;
			}
			long ans = 0;
			for(int i = 0; i < 10; i++)
				ans = (ans + dp[i])%mod;
			out.println(ans);
		}
	}	

	Main() {
		cin = new Scanner(System.in);
		out = new PrintWriter(System.out);
	}

	public static void main(String[] args) {
		Main e = new Main();
		e.work();
		out.close();
	}
	public Scanner cin;
	public static PrintWriter out;
	int max(int x, int y) {
		return x > y ? x : y;
	}

	int min(int x, int y) {
		return x < y ? x : y;
	}

	double max(double x, double y) {
		return x > y ? x : y;
	}

	double min(double x, double y) {
		return x < y ? x : y;
	}
	long max(long x, long y) {
		return x > y ? x : y;
	}

	long min(long x, long y) {
		return x < y ? x : y;
	}

	static double eps = 1e-8;

	int abs(int x) {
		return x > 0 ? x : -x;
	}

	double abs(double x) {
		return x > 0 ? x : -x;
	}
	long abs(long x) {
		return x > 0 ? x : -x;
	}

	boolean zero(double x) {
		return abs(x) < eps;
	}
}




CSU 1354 Distinct Subsequences 求不相同子序列的和 dp

原文:http://blog.csdn.net/qq574857122/article/details/43087573

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!