首页 > 其他 > 详细

DFS--搜索

时间:2014-11-23 00:37:10      阅读:354      评论:0      收藏:0      [点我收藏+]

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73911    Accepted Submission(s): 20238


Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.

 

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

 

 

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

 

 

Sample Output

NO YES
 
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
using namespace std;
char map[10][10];
int vis[10][10];
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
int ax,ay,ex,ey,t,flag=0,n,m;
void dfs(int x,int y,int time)
{
    vis[x][y]=1;
    int s,i;
    s=(t-time)-(abs(x-ex)+abs(y-ey));
    if(s<0||s%2)
    return;
    if(time>=t)
    {
        if(x==ex&&y==ey)
        {
            flag=1;
        }
    }
    else
    {
        for(i=0;i<4&&flag==0;i++)
        {
            int xx=x+dir[i][0];
            int yy=y+dir[i][1];
            if((map[xx][yy]==‘.‘||map[xx][yy]==‘S‘||map[xx][yy]==‘D‘)&&xx>=0&&xx<n&&yy>=0&&yy<m&&vis[xx][yy]==0)
            {
                dfs(xx,yy,time+1);
                vis[xx][yy]=0;
            }
        }
    }
}
int main()
{
    int i,j,s;
    while(~scanf("%d%d%d",&n,&m,&t)&&n&&m&&t)
    {
        getchar();
        memset(map,0,sizeof(map));
        memset(vis,0,sizeof(vis));
        flag=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]==‘S‘)
                {
                    ax=i;ay=j;
                }
                if(map[i][j]==‘D‘)
                {
                    ex=i;ey=j;
                }
            }
            getchar();
        }
        dfs(ax,ay,0);
        if(flag==1)
        printf("YES\n");
        else
        printf("NO\n");
    }
    return 0;
}

 

DFS--搜索

原文:http://www.cnblogs.com/gk-blog/p/4116018.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!