首页 > 其他 > 详细

夏令时【Daylight Saving Time】时间计算出错的解决办法

时间:2014-02-25 20:59:49      阅读:357      评论:0      收藏:0      [点我收藏+]

单调队列优化DP :
dp[ i ] [ j ] = max{ dp[ i-1 ] [ j ]  ,  dp[ i - w -1 ] [ k ] - ( j - k )*ap[ i ]  ,  dp [ i - w - 1 ] [ k ] + ( k - j )*bp[ i ]  }
后两项 dp [ i - w - 1 ][ k ] + k* xx - j * xx 且 abs( j - x) < yy 可以维护一个单调递减的队列。。。

Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3156    Accepted Submission(s): 1008


Problem Description
Recently, lxhgww is addicted to stock, he finds some regular patterns after a few days‘ study.
He forecasts the next T days‘ stock market. On the i‘th day, you can buy one stock with the price APi or sell one stock to get BPi. 
There are some other limits, one can buy at most ASi stocks on the i‘th day and at most sell BSi stocks.
Two trading days should have a interval of more than W days. That is to say, suppose you traded (any buy or sell stocks is regarded as a trade)on the i‘th day, the next trading day must be on the (i+W+1)th day or later.
What‘s more, one can own no more than MaxP stocks at any time.

Before the first day, lxhgww already has infinitely money but no stocks, of course he wants to earn as much money as possible from the stock market. So the question comes, how much at most can he earn?
 

Input
The first line is an integer t, the case number.
The first line of each case are three integers T , MaxP , W .
(0 <= W < T <= 2000, 1 <= MaxP <= 2000) .
The next T lines each has four integers APi,BPi,ASi,BSi( 1<=BPi<=APi<=1000,1<=ASi,BSi<=MaxP), which are mentioned above.
 

Output
The most money lxhgww can earn.
 

Sample Input
1 5 2 0 2 1 1 1 2 1 1 1 3 2 1 1 4 3 1 1 5 4 1 1
 

Sample Output
3
 

Author
lxhgww
 

Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <algorithm>

using namespace std;

const int maxn=2200;

int N,P,W,dp[maxn][maxn],ap[maxn],bp[maxn],as[maxn],bs[maxn];

struct node
{
    int val,pos;
}que[maxn];

void solve()
{
    int head,tail,pre;

    memset(dp,0xcf,sizeof(dp));

    for(int i=1;i<=N;i++)
    {
        for(int j=0;j<=min(as[i],P);j++)
        {
            dp[i][j]=-ap[i]*j;
        }
    }

    for(int i=2;i<=N;i++)
    {
        for(int j=0;j<=P;j++)
        {
            dp[i][j]=max(dp[i-1][j],dp[i][j]);
        }
    }

    for(int i=W+2;i<=N;i++)
    {
        pre=i-W-1;
        head=0,tail=-1;
        for(int j=0;j<=P;j++)///buy
        {
            dp[i][j]=max(dp[i-1][j],dp[i][j]);

            node temp;
            temp.val=dp[pre][j]+j*ap[i];
            temp.pos=j;

            while(head<=tail&&que[tail].val<temp.val) tail--;
            que[++tail]=temp;
            while(head<=tail&&(j-que[head].pos)>as[i]) head++;

            if(head<=tail)
            {
                dp[i][j]=max(dp[i][j],que[head].val-j*ap[i]);
            }
        }

        head=0;tail=-1;
        for(int j=P;j>=0;j--)///sell
        {
            dp[i][j]=max(dp[i-1][j],dp[i][j]);

            node temp;
            temp.val=dp[pre][j]+bp[i]*j;
            temp.pos=j;

            while(head<=tail&&que[tail].val<temp.val) tail--;
            que[++tail]=temp;
            while(head<=tail&&(que[head].pos-j)>bs[i]) head++;

            if(head<=tail)
            {
                dp[i][j]=max(dp[i][j],que[head].val-bp[i]*j);
            }
        }
    }
}

int main()
{
    int cas;
    scanf("%d",&cas);
while(cas--)
{
    scanf("%d%d%d",&N,&P,&W);
    for(int i=1;i<=N;i++) scanf("%d%d%d%d",ap+i,bp+i,as+i,bs+i);
    solve();
    printf("%d\n",dp[N][0]);
}
    return 0;
}





夏令时【Daylight Saving Time】时间计算出错的解决办法

原文:http://blog.csdn.net/jcx5083761/article/details/19864715

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!