首页 > 其他 > 详细

二分求值

时间:2014-02-22 11:13:26      阅读:240      评论:0      收藏:0      [点我收藏+]

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6753    Accepted Submission(s): 3151


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

 

Sample Input
2 100-4
 

 

Sample Output
1.6152 No solution!

 

bubuko.com,布布扣
#include<iostream>
#include<cstdio>
using namespace std;
double f(double m){
    return 8 * m*m*m*m + 7 * m*m*m + 2 * m*m + 3 * m + 6;
}
int main()
{
    int t;
    double y;
    cin >> t;
    while (t--){
        cin >> y;
        if (y<f(0) || y>f(100)){ cout << "No solution!\n"; continue; }//没想起来怎么判断,唉
        double h = 0, e = 100, m;
        for (int i = 0; i < 100; i++){
            m = (h + e) / 2;
            if ( f(m)< y)h = m;
            else e = m;
        }
        printf("%.4lf\n", m);
    }
    return 0;
}
bubuko.com,布布扣

二分求值

原文:http://www.cnblogs.com/littlehoom/p/3560192.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!