首页 > 移动平台 > 详细

如何解决IOS 15提示“此App的开发者需要更新APP以在此IOS版本上正常工作”, 无法打开安装的APP的问题

时间:2021-06-16 14:40:50      阅读:838      评论:0      收藏:0      [点我收藏+]

在苹果手机最新的IOS 15 beta的系统上安装自签名或者企业签名的APP时,可能会遇到如下的错误提示:

 

此App的开发者需要更新APP以在此IOS版本上正常工作

The developer of this app needs to update it to work with this version of iOS

0xe8008029 (The code signature version is no longer supported.)

 

技术分享图片

 

这个错误是由于APP使用了老版本格式的签名导致的,因此我们需要更新APP的签名,才可以使APP正常工作

 

需要准备的材料:

1. APP签名证书

2. 无法安装的IPA文件

3. 安装有苹果应用IPA一键签名工具1.8.0或者以上版本的电脑: IOS苹果应用IPA一键签名工具(苹果重签名,企业签名,Windows平台,时间控制) - 翠翠不脆 - 博客园 (cnblogs.com)

 

解决“此App的开发者需要更新APP以在此IOS版本上正常工作”的步骤:

1. 打开软件苹果应用IPA一键签名工具,等待初始化完成

技术分享图片

 

2.在软件主界面中,选择签名单个IPA文件

技术分享图片

 

3. 选择需要重签名的IPA文件,点击添加按钮添加证书文件

技术分享图片

 

4.可以填入自定义的BundleID,如果不填,则默认使用原本IPA文件中的BundleID

 

5.特殊ID可以用来区分相同BundleID的应用,如果希望可以在管理页中管理多个相同BundleID的应用而不会覆盖,可以填写特殊ID

 

6.勾选注入管理模块

 

7.所有配置完成后,如下所示

技术分享图片

 

8.点击开始签名按钮进行签名,签名成功后,会自动提示打开文件夹

 

9. 在IPA管理页面里,右键点击“安装IPA”

技术分享图片

 

 

10. 点击后,会生成一个安装二维码,试用手机系统自带相机扫码即可完成安装

技术分享图片

 

此时APP便可以正常安装并启动了

 

如何解决IOS 15提示“此App的开发者需要更新APP以在此IOS版本上正常工作”, 无法打开安装的APP的问题

原文:https://www.cnblogs.com/reachteam/p/14888792.html

(0)
(0)
   
举报
评论 一句话评论(0
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!