Pseudoprime numbers
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 6544Accepted: 2648
Description
Fermat‘s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this
property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.
Input
Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.
Output
For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".
Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample Output
no
no
yes
no
yes
yes
Source
Waterloo Local Contest, 2007.9.23
题目大意:费马定理:a^p = a(mod p) (a为大于1的整数,p为素数),一些非素数p,同样也符合上边的
定理,这样的p被称作基于a的伪素数,给你p和a,判断p是否是基于a的伪素数
思路:很简单的快速幂取余+素性判断
如果p为素数,则直接输出no
如果p不为素数,则进行快速幂取余判断是否为伪素数,若是,输出yes,不是,输出no
#include<stdio.h>
#include<math.h>
__int64 QuickPow(__int64 a,__int64 p)
{
__int64 r = 1,base = a;
__int64 m = p;
while(p!=0)
{
if(p&1)
r = r * base % m;
base = base * base % m;
p >>= 1;
}
return r;
}
bool IsPrime(__int64 p)
{
for(__int64 i = 2; i <= sqrt(p) + 1; i++)
{
if(p % i == 0)
return false;
}
return true;
}
int main()
{
__int64 a,p;
while(~scanf("%I64d %I64d",&p,&a) && (p!=0 || a!=0))
{
if(IsPrime(p))
printf("no\n");
else
{
if(QuickPow(a,p) == a)
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}
POJ3641_Pseudoprime numbers【快速幂】【伪素数】
原文:http://blog.csdn.net/lianai911/article/details/39471919