Problem Description
There is a pile of n wooden sticks. The length and
weight of each stick are known in advance. The sticks are to be processed by a
woodworking machine in one by one fashion. It needs some time, called setup
time, for the machine to prepare processing a stick. The setup times are
associated with cleaning operations and changing tools and shapes in the
machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right
after processing a stick of length l and weight w , the machine will need no
setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘.
Otherwise, it will need 1 minute for setup.
You are to find the minimum
setup time to process a given pile of n wooden sticks. For example, if you have
five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and
(1,4), then the minimum setup time should be 2 minutes since there is a sequence
of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of
test cases (T) is given in the first line of the input file. Each test case
consists of two lines: The first line has an integer n , 1<=n<=5000, that
represents the number of wooden sticks in the test case, and the second line
contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at
most 10000 , where li and wi are the length and weight of the i th wooden stick,
respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in
minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4
3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output

/*************************************************************************************************************
题意:有n木棒,给出长度和重量,首先setup耗时+1 如果i+1根木棒的长度和重量均小于i 则不耗时
否则重新setup time 耗时+1 求出最少的setup time
思路:首先按关键字进行排序 然后遍历找出符合条件的元素
*************************************************************************************************************/
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
typedef struct
{
int l;
int w;
}st;
st a[5000+10];
bool flag[5000+10];
bool cmp(st x , st y)
{
if(x.l == y.l) return x.w < y.w;
return x.l < y.l;
}
int main()
{
//freopen("data.in", "r", stdin);
//freopen("data.out", "w", stdout);
int t;
scanf("%d", &t);
while(t--)
{
memset(flag , false , sizeof(flag));
int n;
scanf("%d", &n);
for(int i = 0 ; i < n ; i++)
scanf("%d %d", &a[i].l, &a[i].w);
sort(a, a + n , cmp);
int ans = 0;
for(int i = 0 ; i < n ; i ++)
{
if(flag[i])
continue;
st temp = a[i];
ans++;
for(int j = i + 1; j < n ; j++)
{
if(a[j].l <= temp.l && a[j].w <= temp.w && !flag[j])
{
flag[j] = true;
temp = a[j];
}
}
}
printf("%d\n" , ans);
}
return 0;
}

【贪心】【POJ-1065&&HDOJ-1051&&AOJ-224】Wooden
Sticks
原文:http://www.cnblogs.com/ahu-shu/p/3556295.html