首页 > 其他 > 详细

HDU 1003

时间:2020-11-14 13:05:53      阅读:16      评论:0      收藏:0      [点我收藏+]

HDU 1003

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

#include<stdio.h>
int main(){
	int m,n,i,j,max,sum,k,start,end;
	int num[100000];
	while(scanf("%d",&m)!=EOF){
		for(i=1;i<=m;i++){
			scanf("%d",&n);
			for(j=0;j<n;j++) scanf("%d",&num[j]);
			max=num[0];sum=0;start=0;end=0;k=0;
			for(j=0;j<n;j++){
				sum+=num[j];
				if(sum>max){
					max=sum;
					start=k;
					end=j;
				}
					if(sum<0){
						sum=0;
						k=j+1;
			}
		}
			if(i!=1)printf("\n"); 
			printf("Case %d:\n%d %d %d\n",i,max,start+1,end+1);
		}
	}
} 

思路就是一次遍历
遇到总和小于0的就丢弃 重新计数sum
将其与max进行比较

HDU 1003

原文:https://www.cnblogs.com/Dios314/p/13972515.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!