首页 > 其他 > 详细

最短路+DFS

时间:2014-02-19 01:29:43      阅读:475      评论:0      收藏:0      [点我收藏+]
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
A Walk Through the Forest
 
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5071    Accepted Submission(s): 1846
 
 
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
  
 
Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
  
 
Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
  
 
Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
  
 
Sample Output
2
4

  好难的题,好漂亮的深搜啊!

bubuko.com,布布扣
#include<iostream>
#include<algorithm>
#define MAX 1002
#define INF (1<<29)
using namespace std;
int cost[MAX][MAX];
__int64 d[MAX];//最短距离
int n, num[MAX];//个数,
bool used[MAX];
void dijkstra(int s){
    int v = -1;
    fill(d, d + MAX, INF);
    fill(used, used + MAX, false);
    d[s] = 0;
    while (true){
        v = -1;
        for (int i = 1; i <=n; i++){
            if (!used[i] && (v == -1 || d[v]>d[i]))v = i;
        }
        if (v == -1)break;
        used[v] = true;
        for (int i = 1; i <=n; i++){
            d[i] = min(d[i], d[v] + cost[v][i]);
        }
    }
}
__int64 dfs(int i){
    if (i == 2)return 1;//找到一条路
    if (num[i] != -1)return num[i];//i到home的路数已经求过,直接返回
    num[i] = 0;
    for (int j = 1; j <= n; j++){
        if (cost[i][j] != INF && d[i] > d[j]){
            num[i] += dfs(j);
        }
    }
    return num[i];
}
int main()
{
    int m, a, b, c;
    while (true){
        cin >> n;
        if (n == 0)break;
        cin >> m;
        for (int i = 1; i <= n; i++){
            fill(cost[i], cost[i] + MAX, INF);
        }
        for (int i = 0; i < m; i++){
            cin >> a >> b >> c;
            if (c < cost[a][b]){
                cost[a][b] = cost[b][a] = c;
            }
        }
        dijkstra(2);//从home到每个点的最短距离
        fill(num, num + MAX, -1);
        cout << dfs(1) << endl;
    }
    return 0;
}
bubuko.com,布布扣

最短路+DFS

原文:http://www.cnblogs.com/littlehoom/p/3554385.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!