首页 > 其他 > 详细

POJ 3641 Pseudoprime numbers 测试费马小定理伪素数

时间:2014-02-18 16:15:09      阅读:367      评论:0      收藏:0      [点我收藏+]
Pseudoprime numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6018   Accepted: 2407

Description

Fermat‘s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source


费马小定理:若p是素数且a是正整数,那么a^p=a(mod p)
若a是正整数,p是合数且满足a^p=a(mod p),那么称p为以a为基的伪素数。
给你p和a,让你判断p是不是伪素数。
//384K	16MS
#include<stdio.h>
#include<math.h>
bool isprime(long long x)//判断x是不是素数,如果是素数,肯定不是伪素数
{
    if(x==1||x==2)return true;
    long long tmp=sqrt(x);
    for(long long i=2;i<=tmp;i++)
        if(x%i==0)return false;
    return true;
}
long long quick_mod(long long a,long long b,long long m)//快速幂求a^b%m
{
    long long ans=1;
    while(b)
    {
        if(b&1){ans=(ans*a)%m;b--;}
        b/=2;
        a=a*a%m;
    }
    return ans;
}
int main()
{
    long long p,a;
    while(scanf("%lld%lld",&p,&a),p|a)
    {
        if(isprime(p)){printf("no\n");continue;}
        long long mol=quick_mod(a,p,p);
        if(mol==a%p)printf("yes\n");
        else printf("no\n");
    }
    return 0;
}


POJ 3641 Pseudoprime numbers 测试费马小定理伪素数

原文:http://blog.csdn.net/crescent__moon/article/details/19397947

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!