首页 > 其他 > 详细

PAT 甲级 1106 Lowest Price in Supply Chain (25分) (bfs)

时间:2020-01-29 23:56:47      阅读:152      评论:0      收藏:0      [点我收藏+]
1106 Lowest Price in Supply Chain (25分)
 

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID‘s are numbered from 0 to N1, and the root supplier‘s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K?i?? ID[1] ID[2] ... ID[K?i??]

where in the i-th line, K?i?? is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID‘s of these distributors or retailers. K?j?? being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
 

Sample Output:

1.8362 2

 

题意:

供应链由零销商、经销商、供应商组成,从供应商开始,供应链上的每个人在购买货物的时候需要支付比原价格多r%的费用,供应链上不存在环,本题要求求出顾客为购买货物支付的最少费用,并且求出最低价格的供应链存在的条数.

题解:

bfs。先根据入度找到根节点root。用vector保存路径。接着bfs,记录下所有节点的深度depth。最后遍历所有零销商,找到depth最小的即可。开始看成路径最长,价格最贵的了。。。。应该是价格最低的。

AC代码:

#include<bits/stdc++.h>
using namespace std;
vector<int>v[100005];
queue<int>q;
double p,r;
int n;
int in[100005];
int depth[100005];
int main(){
    cin>>n>>p>>r;
    for(int i=0;i<n;i++){
        int m;
        cin>>m;
        for(int j=1;j<=m;j++){
            int x;
            cin>>x;
            v[i].push_back(x);
            in[x]++;
        }
    }
    int root=-1;
    for(int i=0;i<n;i++){
        if(in[i]==0){
            root=i;
            break;
        }
    }
    depth[root]=0;
    q.push(root);
    //cout<<"根"<<root<<endl;
    while(!q.empty()){
        int x=q.front();
        q.pop();
        //cout<<"v[x].size()"<<v[x].size()<<endl; 
        for(int i=0;i<v[x].size();i++){
            int y=v[x].at(i);
            depth[y]=depth[x]+1;
            q.push(y);
            //cout<<"到"<<y<<"距离"<<depth[y]<<endl;
        }
    }
    int mm=100005;
    int num=1;
    for(int i=0;i<n;i++){
        if(v[i].size()==0){
            if(depth[i]<mm){
                mm=depth[i];
                num=1;
            }else if(depth[i]==mm) num++;
        }
    }
    for(int i=1;i<=mm;i++){
        p=p*(1+r*0.01);
    }
    printf("%.4lf %d",p,num);
    return 0;    
} 

 

PAT 甲级 1106 Lowest Price in Supply Chain (25分) (bfs)

原文:https://www.cnblogs.com/caiyishuai/p/12241811.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!