首页 > 其他 > 详细

pat1001

时间:2019-12-25 23:21:36      阅读:77      评论:0      收藏:0      [点我收藏+]
1001 A+B Format (20分)
 

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9
 

Sample Output:

-999,991

长度余3的地方插进去一个逗号,正数的话i要加1,负号占了一个下标不用加。数字的最后面和最前面也不用加逗号。
#include<bits/stdc++.h>
using namespace std;
#define _for(i, a, b) for (int i = (a); i <= (b); i++)
int main()
{
    char s[15], rs[15];
    int a, b, c;
    cin >> a >> b;
    c = a + b;
    sprintf(s,"%d",c);
    int len = strlen(s);
    for (int i = 0; i < len;i++){
        printf("%c", s[i]);
        if(s[0]==‘-‘){
            if((i)%3==(len-1)%3&&i!=len-1&&i!=0){
                printf(",");
            }
        }else{
            if ((i+1) % 3 == len % 3 && i != len - 1)
            {
                printf(",");
            }
        }
    }
    puts("");
    return 0;
}











pat1001

原文:https://www.cnblogs.com/zlwjy/p/12099205.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!