首页 > 其他 > 详细

HDU 1018:Big Number (位数递推公式)

时间:2019-09-30 01:00:44      阅读:123      评论:0      收藏:0      [点我收藏+]

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19

 

#include <cstdio>
#include <string.h>
#define N 1024
#define MAXN 0x3f3f3f3f
#include <map>
#include <string>
#include <cmath>
#define pi acos(-1.0)
#include <algorithm>
#include <iostream>
#include <iomanip>
#include <set>
using namespace std;
int main()
{
    int n,m,t;
    cin>>t;
    while(t--)
    {
        double sum=0;
        cin>>n;
        for(double i=1;i<=n;i++)
            sum+=log10(i);
        cout<<(int)sum+1<<endl;

    }
    return 0;
}

 

HDU 1018:Big Number (位数递推公式)

原文:https://www.cnblogs.com/Shallow-dream/p/11610481.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!