首页 > 其他 > 详细

USACO Balanced Lineup

时间:2019-07-12 13:18:27      阅读:83      评论:0      收藏:0      [点我收藏+]

poj 3264

http://poj.org/problem?id=3264

洛谷 P2880

https://www.luogu.org/problemnew/show/P2880

题目描述

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

一个农夫有N头牛,每头牛的高度不同,我们需要找出最高的牛和最低的牛的高度差。

输入输出格式

输入格式:

 

Line 1: Two space-separated integers, N and Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

 

输出格式:

 

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

 

输入输出样例

输入样例#1: 复制
6 3
1
7
3
4
2
5
1 5
4 6
2 2
输出样例#1: 复制
6
3
0

RMQ的裸题,直接用ST算法AC就可以。
跑一遍最大值再来一遍最小值。
AC Code:
#include<cstdio>
#include<algorithm>
using namespace std;
int n,q;
int lg[50001];
int f[50001][16],p[50001][16];
int main()
{
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&f[i][0]);
        p[i][0]=f[i][0];
    }
    for(int i=2;i<=n;i++)
        lg[i]=lg[i>>1]+1;
    for(int j=1;(1<<j)<=n;j++)
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            f[i][j]=max(f[i][j-1],f[i+(1<<(j-1))][j-1]);
            p[i][j]=min(p[i][j-1],p[i+(1<<(j-1))][j-1]);
        }
    for(int i=1;i<=q;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        int k=lg[y-x+1];
        printf("%d\n",max(f[x][k],f[y-(1<<k)+1][k])-min(p[x][k],p[y-(1<<k)+1][k]));
    }
    return 0;
}

 

USACO Balanced Lineup

原文:https://www.cnblogs.com/fusiwei/p/11175456.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!