首页 > 其他 > 详细

HDU - 5533 G - Dancing Stars on Me(思维)

时间:2019-05-22 21:37:25      阅读:101      评论:0      收藏:0      [点我收藏+]
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

InputThe first line contains a integer TT indicating the total number of test cases. Each test case begins with an integer nn, denoting the number of stars in the sky. Following nn lines, each contains 22 integers xi,yixi,yi, describe the coordinates of nn stars.

1T3001≤T≤300
3n1003≤n≤100
10000xi,yi10000−10000≤xi,yi≤10000
All coordinates are distinct.
OutputFor each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).Sample Input

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

Sample Output

NO
YES
NO
思路:多边形中,n个点对任意其他点的距离,总共有n/2种不同的长度,利用这个规则,可直接求。
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
using namespace std;

int t, n, x[100+8], y[100+8];
map<int, int>len;

int main()
{
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        len.clear();//一定要记得清空,不然size会改变,插入的时候也会继续往后插
        int ii = 0;
        for(int i = 0; i<n; i++)
            scanf("%d%d", &x[i], &y[i]);
        for(int i = 0; i<n; i++)
            for(int j = i+1; j<n; j++)
                len[(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])] = 1;
        if(len.size() == n/2)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

HDU - 5533 G - Dancing Stars on Me(思维)

原文:https://www.cnblogs.com/RootVount/p/10908440.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!