Matrix multiplication
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2113 Accepted Submission(s): 956
Problem Description
Given two matrices A and B of size n×n, find the product of them.
bobo hates big integers. So you are only asked to find the result modulo 3.
Input
The input consists of several tests. For each tests:
The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals Aij. The next n lines describe the matrix B in similar format (0≤Aij,Bij≤109).
Output
For each tests:
Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
Sample Input
Sample Output
Author
Xiaoxu Guo (ftiasch)
Source
直接矩阵相乘,果断TLE。要用求稀疏矩阵的方法来解此题,才能ac,果断卡时间。
//1703MS 7868K
#include<stdio.h>
#include<string.h>
#define M 3
int a[807][807],b[807][807],c[807][807];
int n;
void init()//建立矩阵
{
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
scanf("%d",&a[i][j]);
a[i][j]%=M;
}
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
scanf("%d",&b[i][j]);
b[i][j]%=M;
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
init();
memset(c,0,sizeof(c));
for(int i=0;i<n;i++)
for(int k=0;k<n;k++)
if(a[i][k])
for(int j=0;j<n;j++)
c[i][j]=(c[i][j]+a[i][k]*b[k][j])%3;
for(int i=0;i<n;i++)
{
for(int j=0;j<n-1;j++)
printf("%d ",c[i][j]);
printf("%d\n",c[i][n-1]);
}
}
return 0;
}
HDU 4902 Matrix multiplication,布布扣,bubuko.com
HDU 4902 Matrix multiplication
原文:http://blog.csdn.net/crescent__moon/article/details/38425247