首页 > 其他 > 详细

UVA10061 How many zero's and how many digits ?【不同进制因子分解】

时间:2019-02-24 11:26:58      阅读:149      评论:0      收藏:0      [点我收藏+]

Given a decimal integer number you will have to find out how many trailing zeros will be there in its factorial in a given number system and also you will have to find how many digits will its factorial have in a given number system? You can assume that for a b based number system there are b different symbols to denote values ranging from 0 . . . b ? 1.
Input
There will be several lines of input. Each line makes a block. Each line will contain a decimal number N (a 20bit unsigned number) and a decimal number B (1 < B ≤ 800), which is the base of the number system you have to consider. As for example 5! = 120 (in decimal) but it is 78 in hexadecimal number system. So in Hexadecimal 5! has no trailing zeros.
Output
For each line of input output in a single line how many trailing zeros will the factorial of that number have in the given number system and also how many digits will the factorial of that number have in that given number system. Separate these two numbers with a single space. You can be sure that the number of trailing zeros or the number of digits will not be greater than 231 ? 1.
Sample Input
2 10
5 16
5 10
Sample Output
0 1
0 2
1 3

问题链接UVA10061 How many zero‘s and how many digits ?
问题简述:(略)
问题分析
????先占个位置。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10061 How many zero's and how many digits ? */

#include <bits/stdc++.h>

using namespace std;

const int N = 1000;
int num[N];

int zero(int n, int base){
    memset(num, 0, sizeof(num));

    for (int i = 2; i <= n; i++)
        for (int j = 2, g = i; j <= g && j <= base; j++){
            while (g % j == 0){
                num[j]++;
                g = g / j;
            }
        }

    int cnt = 0;
    for(;;){
        int g = base;
        for (int j = 2; j <= base; j++){
            while (g % j == 0){
                if (num[j] > 0)
                    num[j]--;
                else
                    return cnt;
                g = g / j;
            }
        }
        cnt++;
    }
    return cnt;
}

int digit(int n, int base) {
    double sum = 0;
    for (int i = 1; i <= n; i++) {
        sum += log10(i);
    }
    sum /= log10(base);
    return floor(sum + 1e-9) + 1;
}

int main()
{
    int n, b;
    while (scanf("%d %d",&n, &b) == 2)
        printf("%d %d\n", zero(n, b), digit(n, b));

    return 0;
}

UVA10061 How many zero's and how many digits ?【不同进制因子分解】

原文:https://www.cnblogs.com/tigerisland45/p/10425612.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!