首页 > 编程语言 > 详细

hdu1002-A + B Problem II-(java大数)

时间:2019-02-17 16:00:11      阅读:288      评论:0      收藏:0      [点我收藏+]

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 460526    Accepted Submission(s): 89173


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
import java.math.BigInteger;//操作大型整数
import java.math.BigDecimal;//操作大型小数
import java.util.Scanner;
import java.util.Arrays;
public class Main//hdu1002
{
    public static void main(String []args)
    {    
        BigInteger a,b,sum;
        Scanner scan=new Scanner(System.in);
        int t;
        t=scan.nextInt();
        for(int i=1;i<=t;i++)
        {
            a=scan.nextBigInteger();
            b=scan.nextBigInteger();
            sum=a.add(b);
            System.out.println("Case "+i+":");
            System.out.println(a+" + "+b+" = "+sum);
            if(i!=t)
                System.out.println();    
        }
    }
}

 

hdu1002-A + B Problem II-(java大数)

原文:https://www.cnblogs.com/shoulinniao/p/10391426.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!