首页 > 其他 > 详细

HDU 4908——BestCoder Sequence

时间:2014-08-04 11:13:07      阅读:334      评论:0      收藏:0      [点我收藏+]

BestCoder Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 169    Accepted Submission(s): 82


Problem Description
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are bestcoder sequences in a given permutation of 1 ~ N.
 

Input
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 

Output
For each case, you should output the number of consecutive sub-sequences which are the Bestcoder Sequences
 

Sample Input
1 1 1 5 3 4 5 3 2 1
 

Sample Output
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.



————————————————————————————————————————————

<strong><span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define M 100001
#define base 40000
using namespace std;
int a[M],dp[M];
int main()
{
    int n,m,x;
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<n;++i){
            scanf("%d",&a[i]);
            if(a[i]==m) x=i;
        }
        memset(dp,0,sizeof dp);
        int ans=0;
        for(int i=x+1;i<n;++i){
            if(a[i]>m) ans++;  //大的加小的减
            else ans--;
            dp[ans+base]++;    //记录出现该状态的次数
        }
        ans=++dp[base];<span style="white-space:pre">		</span>//当状态数为base,才满足中位数
        int tmp=0;
        for(int i=x-1;i>=0;--i){
            if(a[i]>m) tmp++;
            else tmp--;
            ans+=dp[-tmp+base];<span style="white-space:pre">		</span>状态相加为base的个数
        }
        cout<<ans<<endl;
    }
    return 0;
}</span></strong>



















1242

HDU 4908——BestCoder Sequence,布布扣,bubuko.com

HDU 4908——BestCoder Sequence

原文:http://blog.csdn.net/u014141559/article/details/38364655

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!