首页 > 其他 > 详细

PAT 甲级 1035 Password

时间:2018-08-05 17:20:14      阅读:163      评论:0      收藏:0      [点我收藏+]

https://pintia.cn/problem-sets/994805342720868352/problems/994805454989803520

 

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

代码:
#include <bits/stdc++.h>
using namespace std;

char username[20], pw[20];
char userr[1111][20], pww[1111][20];
char s1[5] = {‘1‘, ‘0‘, ‘l‘, ‘O‘};
char s2[5] = {‘@‘, ‘%‘, ‘L‘, ‘o‘};

int yes(char a[20]) {
    int len = strlen(a);
    bool flag = false;
    for(int i = 0; i < len; i ++) {
        for(int j = 0; j <= 3; j ++) {
            if(a[i] == s1[j])
                flag = true;
        }
    }
    if(flag) return 1;
    else return 0;
}

int main() {
    int n;
    scanf("%d", &n);
    int cnt = 0;
    for(int i = 1; i <= n; i ++) {
        scanf("%s%s", username, pw);
        cnt += yes(pw);
        if(yes(pw) == 1) {
            strcpy(userr[cnt], username);
            int lenn = strlen(pw);
            for(int j = 0; j < lenn; j ++) {
                for(int k = 0; k <= 3; k ++) {
                    if(pw[j] == s1[k])
                        pw[j] = s2[k];
                }
            }
            strcpy(pww[cnt], pw);
        }
    }

    if(cnt == 0) {
        if(n == 1)
            printf("There is 1 account and no account is modified\n");
        else
            printf("There are %d accounts and no account is modified\n", n);
    } else {
        printf("%d\n", cnt);
        for(int i = 1; i <= cnt; i ++)
            printf("%s %s\n", userr[i], pww[i]);
    }

    return 0;
}

  

PAT 甲级 1035 Password

原文:https://www.cnblogs.com/zlrrrr/p/9426355.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!