首页 > 其他 > 详细

HDU 2018 母牛的故事

时间:2018-07-17 00:32:43      阅读:237      评论:0      收藏:0      [点我收藏+]

http://acm.hdu.edu.cn/showproblem.php?pid=2018

 

Problem Description
有一头母牛,它每年年初生一头小母牛。每头小母牛从第四个年头开始,每年年初也生一头小母牛。请编程实现在第n年的时候,共有多少头母牛?
 
Input
输入数据由多个测试实例组成,每个测试实例占一行,包括一个整数n(0<n<55),n的含义如题目中描述。
n=0表示输入数据的结束,不做处理。
 
Output
对于每个测试实例,输出在第n年的时候母牛的数量。
每个输出占一行。
 
Sample Input
2
4
5
0
 
Sample Output
2
4
6
 
代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;

int A(int x)
{
    if(x<=4)
        return x;
    else
        return A(x-1)+A(x-3);
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        else
            printf("%d\n",A(n));
    }
    return 0;
}

  

HDU 2018 母牛的故事

原文:https://www.cnblogs.com/zlrrrr/p/9321163.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!