首页 > 其他 > 详细

PAT A+B for Polynomials[简单]

时间:2018-07-15 17:00:08      阅读:186      评论:0      收藏:0      [点我收藏+]
1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
using namespace std;
double nk1[1001]={0},nk2[1001]={0};
int main()
{
    //freopen("1.txt","r",stdin);
    int n;
    scanf("%d",&n);
    int a;
    double b;
    while(n--){
        scanf("%d%lf",&a,&b);
        nk1[a]=b;
    }
    scanf("%d",&n);
    while(n--){
        scanf("%d%lf",&a,&b);
        nk2[a]=b;
    }

    for(int i=0;i<1001;i++){
        nk1[i]=nk1[i]+nk2[i];
    }
    int ct=0;
    for(int i=0;i<1001;i++){
        if(nk1[i]!=0){
            ct++;
        }
    }
    printf("%d",ct);
    if(ct!=0)printf(" ");
    for(int i=1000;i>=0;i--){
        if(nk1[i]!=0)
        {printf("%d %.1f",i,nk1[i]);
        ct--;
        if(ct!=0)printf(" ");
        if(ct==0)break;
        }
    }

    return 0;
}

//写的代码有点烂。总之就是遍历呗,没想到很好的办法。就是这样下去。就是多项式对应系数相加。没什么难点。

发现了一个可以改进的地方,就是可以把第二个数组都进来的数直接相加,而不是定义两个数组。减小了空间占用。

 

PAT A+B for Polynomials[简单]

原文:https://www.cnblogs.com/BlueBlueSea/p/9313864.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!