首页 > 其他 > 详细

1016 Phone Bills (25)(25 point(s))

时间:2018-07-14 22:57:08      阅读:222      评论:0      收藏:0      [点我收藏+]

problem

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00

02:00, and so on for each hour in the day.
The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers‘ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

tip

  • 考察对STL库的熟悉情况的模拟题。

answer

#include<bits/stdc++.h>
using namespace std;
#define Max 1010
#define INF 0x3f3f3f3f
#define fi first
#define se second

int rate[25], N;

typedef struct {
    float bill;
    int minutes;
    string begin, end;
}Call;

typedef struct{
    string time, tip, name;
}Time;

typedef struct {
    vector<Time> temp;
    vector<Call> calls;
    float sum;
}Data;

Data D[1010];
map<string, Data> M;
map<string, Data>::iterator IT;

int month[12] = {0, 31};
bool OnOff(string tip){
    return tip.size() == 7 ? true : false;
}

int TranTime(string t) {
    int day, hour, minute;
    day = (t[3]-‘0‘)*10 + t[4]-‘0‘;
    hour = (t[6]-‘0‘)*10 + t[7]-‘0‘;
    minute = (t[9]-‘0‘)*10 + t[10] -‘0‘;
    return (day-1)*24*60 + hour*60 + minute;
}

float CalBill(string t){
    int oneDay = 0;
    int sum = 0;
    for(int i = 0; i < 24; i++){
        oneDay += rate[i]*60;
    }
    int day, hour, minute;
    day = (t[3]-‘0‘)*10 + t[4]-‘0‘;
    hour = (t[6]-‘0‘)*10 + t[7]-‘0‘;
    minute = (t[9]-‘0‘)*10 + t[10] -‘0‘;
    
    sum += day*oneDay;
    for(int i = 0; i < hour; i++)
    {
        sum += rate[i]*60;
    }
    sum += rate[hour]*minute;
    
    return (float)sum/100.0;
}

bool Comp(Time a, Time b){
    return a.time < b.time;
}

int main (){
//  freopen("test.txt", "r", stdin);
    ios::sync_with_stdio(false);
    for(int i = 0; i < 24; i++){
        cin>>rate[i];
    }
    cin>>N;
    for(int i = 0; i < N; i++) {
        string name, time, tip;
        cin>>name>>time>>tip;
        Time t;
        t.name = name;
        t.time = time;
        t.tip  = tip;
        M[t.name].temp.push_back(t);
    }
    for(IT = M.begin(); IT != M.end(); IT++){
        sort(IT->second.temp.begin(), IT->second.temp.end(), Comp);
        vector<Time> a = IT->se.temp;
        stack <Time> sta;
        Call call;
//      cout<<IT->first<<" "<< a[0].time.substr(0,2)<<endl;
        for(int i = 0; i < IT->se.temp.size(); i++){
            if(OnOff(a[i].tip)){
                sta.push(a[i]);
            }else{
                if(sta.empty()) continue;
                call.begin = sta.top().time;
                call.end   = a[i].time;
                call.minutes = TranTime(call.end) - TranTime(call.begin);
                call.bill  = CalBill(call.end) - CalBill(call.begin);
//              cout<<call.begin.substr(3,10)<<" "<<call.end.substr(3, 10)<<" "<<call.minutes<<" $"<<fixed<<setprecision(2)<<call.bill<<endl;
                IT->se.calls.push_back(call);
                IT->second.sum += call.bill;
                while(!sta.empty()) sta.pop();
            }
        }
//      cout<<"Total amount: $"<<fixed<<setprecision(2)<<IT->se.sum<<endl;
    }
    for(IT = M.begin(); IT != M.end(); IT++){
        vector<Time> a = IT->se.temp;
        if(IT->se.calls.size() == 0) continue;
        cout<<IT->first<<" "<< a[0].time.substr(0,2)<<endl;
        for(int i = 0; i < IT->se.calls.size(); i++){
            Call call = IT->se.calls[i];
            cout<<call.begin.substr(3,10)<<" "<<call.end.substr(3, 10)<<" "<<call.minutes<<" $"<<fixed<<setprecision(2)<<call.bill<<endl;
        } 
        cout<<"Total amount: $"<<fixed<<setprecision(2)<<IT->se.sum<<endl;
    }
    return 0;
} 

exprience

  • 模拟题,小心配对错误,与无配对的情况。即是边界条件的考虑。

1016 Phone Bills (25)(25 point(s))

原文:https://www.cnblogs.com/yoyo-sincerely/p/9311076.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!