首页 > 其他 > 详细

1072 Gas Station (30)(30 分)

时间:2018-06-18 16:33:52      阅读:278      评论:0      收藏:0      [点我收藏+]

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 10^3^), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 10^4^), the number of roads connecting the houses and the gas stations; and D~S~, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format\ P1 P2 Dist\ where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution


中途有个判断条件写错了总是有个点 不对,好蠢,station之间的距离可以可以超过range范围,判断的时候只需要判断house,啊。。。好蠢。n个house 1~n,station 1~m加到n后面,总的进行最短路
dijkstra,然后判断,取优。

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <map>
#define inf 0x3f3f3f3f
#define MAX 2020
using namespace std;
int n,m,k,ds,d,mp[MAX][MAX],dis[MAX];
int vis[MAX];
char s1[10],s2[10];
int id,ma,sum;
int change(char *temp) {
    int su = 0,i = 0,j = 0;
    if(temp[0] == G) {
        i ++;
        j += n;
    }
    while(temp[i]) {
        su = su * 10 + temp[i ++] - 0;
    }
    return su + j;
}
void dijkstra() {
    for(int i = n + 1;i <= n + m;i ++) {
        memset(vis,0,sizeof(vis));
        int tsum = 0,tma = 0,flag = 1;
        for(int j = 1;j <= n + m;j ++) {
            dis[j] = mp[i][j];
        }
        while(1) {
            int t = -1,mi = inf;
            for(int j = 1;j <= n + m;j ++) {
                if(!vis[j] && dis[j] < mi){
                    t = j,mi = dis[j];
                }
            }
            if(t == -1)break;
            if(t <= n) {
                if(dis[t] > ds || !tsum && dis[t] < ma) {
                    flag = 0;
                    break;
                }
                else if(!tsum)tma = dis[t];
                tsum += dis[t];
            }
            vis[t] = 1;
            for(int j = 1;j <= n + m;j ++) {
                if(vis[j] || mp[t][j] == inf)continue;
                if(dis[t] + mp[t][j] < dis[j])dis[j] = dis[t] + mp[t][j];
            }
        }
        if(!flag)continue;
        if(tma > ma) {
            id = i;
            ma = tma;
            sum = tsum;
        }
        else if(tsum < sum) {
            sum = tsum;
            id = i;
        }
    }
}
int main() {
    scanf("%d%d%d%d",&n,&m,&k,&ds);
    for(int i = 1;i <= n + m;i ++) {
        for(int j = 1;j <= n + m;j ++) {
            mp[i][j] = inf;
        }
        mp[i][i] = 0;
    }
    for(int i = 0;i < k;i ++) {
        scanf("%s%s%d",s1,s2,&d);
        int x = change(s1),y = change(s2);
        mp[x][y] = mp[y][x] = d;
    }
    dijkstra();
    if(!id)printf("No Solution");
    else printf("G%d\n%.1f %.1f",id - n,(double)ma,(double)sum / (double)n);
}

 

1072 Gas Station (30)(30 分)

原文:https://www.cnblogs.com/8023spz/p/9195311.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!