首页 > 系统服务 > 详细

Linux(ubuntu)下安装pycharm出错Unsupported major.minor version 52.0

时间:2018-03-27 16:05:37      阅读:652      评论:0      收藏:0      [点我收藏+]

标签:version   -i   sim   one   line   height   检测   cin   变量   

已安装python

已安装jdk

在pycharm文件夹中bin中执行sh ./pycharm.sh 时出错:Unsupported major.minor version 52.0

这个错误的意思是JDK版本太低

但是我明明装了版本比较新的jdk,然后我估计是linux自带了jdk,执行命令java -version

查看java版本,果然是版本很低的一个

这时候就按下面步骤查看一下默认的jdk路径:

which java ——查看默认的jdk安装路径

加入出来的是:/usr/bin/java

cd /usr/bin——-进入usr目录下的bin目录下

sudo rm -rf java ———删除默认的java

sudo ln -s $JAVA_HOME/bin/java /usr/bin/java——–将自己安装的java链接到默认java安装路径下(此处必须已经配好JAVA_HOME环境变量)

Java -version ——-检测是否成功

这时候就看到java version已经变成我们自己安装的那一个了

再进到pycharm里面的bin文件夹,在执行sh ./pycharm.sh命令即可安装pycharm

Linux(ubuntu)下安装pycharm出错Unsupported major.minor version 52.0

标签:version   -i   sim   one   line   height   检测   cin   变量   

原文:https://www.cnblogs.com/JoinAJR8194/p/8657780.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号