首页 > 其他 > 详细

poj2591 Set Definition(递推)

时间:2014-07-12 18:10:08      阅读:326      评论:0      收藏:0      [点我收藏+]

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=2591

Description

Set S is defined as follows: 
(1) 1 is in S; 
(2) If x is in S, then 2x + 1 and 3x + 1 are also in S; 
(3) No other element belongs to S. 

Find the N-th element of set S, if we sort the elements in S by increasing order.

Input

Input will contain several test cases; each contains a single positive integer N (1 <= N <= 10000000), which has been described above.

Output

For each test case, output the corresponding element in S.

Sample Input

100
254

Sample Output

418
1461

Source



代码如下:

#include <iostream>
using namespace std;
int a[10000017];
int main()
{
	int i, two = 1, three = 1;
	a[1] = 1;
	for(i = 2; i <= 10000000; i++)
	{
		a[i] = min(a[two]*2+1,a[three]*3+1);
		if(a[i] == a[two]*2+1)
			two++;

		if(a[i] == a[three]*3+1)
			three++;
	}
	int n;
	while(cin >> n)
	{
		cout<<a[n]<<endl;
	}
	return 0;
}


poj2591 Set Definition(递推),布布扣,bubuko.com

poj2591 Set Definition(递推)

原文:http://blog.csdn.net/u012860063/article/details/37723807

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!