首页 > 其他 > 详细

RIP总结及案例应用分析配置

时间:2018-03-13 23:41:19      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:网络协议   路由交换   RIP   案例分析   

RIP协议知识脑图总结

技术分享图片



案例分析:
技术分享图片

案例的拓扑图如图所示:
实验环境 IOU Web
要求:1.R1为ISP,只能在其上配置IP地址,不得进行其他配置
2.R2-R6运行RIP V2 , R7-R8运行RIP V1
3.R7的环回地址为172.16.1.0/24
R8的环回地址为172.16.1.0/24
R7-R8之间为78.1.1.0/24
其他网段均使用192.168.1.0/24 合理划分网段
4.R2 去R5的环回通过R3访问
5.R2-R8均可以访问R1 ISP
6.R1telnetR2 实际telnet R8


分析: 首先合理划分地址 R1-R2网段为12.1.1.0/24, R1环回为1.1.1.1/32, R7的环回地址为172.16.1.0/24, R8的环回地址为172.16.1.0/24, R7-R8之间为78.1.1.0/24
主要是R2-R6的地址划分:
192.168.1.0/24 先划分为192.168.1.0/27,其中 把子网192.168.1.0/27再化成192.168.1.0/30 用来给R2-R6-R7的骨干链路的网段分配。
192.168.1.32/28 192.168.1.48/28 R2环回
192.168.1.64/28 192.168.1.80/28 R3环回
192.168.1.96/28 192.168.1.112/28 R4环回
192.168.1.128/28 192.168.1.144/28 R5环回
192.168.1.160/28 192.168.1.176/28 R6环回
第二部分的重点是RIP V2 与 RIP V1之间的兼容问题,V1设备的接口无论设置为收发V1/V2 路由都是没有影响的,它只能发送V1路由,V1只是把目标路由变为224.0.0.9而已,路由不变,不带掩码。 V2设备就不一样,发送V1,就会发送真正的V1路由。所以我们在R6与R7之间值得考虑一下如何设置。
第三部分就是V1的不连续子网问题。如果两个设备的环回是连续子网,而中间的链路不是连续子网,那么这两个设备之间是无法学习到环回的。因为V1在发送路由时是不携带子网掩码,它会携带直连网段的掩码。所以我们需要给R7-R8之间配置第二地址。
接下里就是R6与R7之间的收发V1V2问题。 如果R6往下发V1路由,那么能会把子网掩码为/30的路由发过去,因为R6与R7之间的网段是/30 R6与R2/R5之间也是/30网段 连续子网问题。 最好的解决办法就是R6往下发送V2路由 而R7往上发送的路由是无所谓的,V1发送不了真正的V2路由。
最后就是用NAT做映射访问ISP,并且用NAT静态映射使ISPtelnetR1 实际访问R8。还有就是用偏移列表干涉RIP的选路问题,在R6上抓取R5的环回路由加度量,使得R2 去R5通过R3访问。

            **      配置:**

                **      R1配置**
  interface Loopback0
  ip address 1.1.1.1 255.255.255.255
  !         
   interface Ethernet0/0
   ip address 12.1.1.1 255.255.255.0

 **R2配置*
 接口的配置:

interface Loopback0
ip address 192.168.1.33 255.255.255.240
!
interface Loopback1
ip address 192.168.1.49 255.255.255.240
!
interface Ethernet0/0
ip address 12.1.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip summary-address rip 192.168.1.32 255.255.255.224
!
interface Ethernet0/2
ip address 192.168.1.18 255.255.255.252
ip nat inside
ip virtual-reassembly in
ip summary-address rip 192.168.1.32 255.255.255.224
RIP配置:
router rip
version 2
network 192.168.1.0
default-information originate
no auto-summary
NAT配置:
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source static 172.16.2.1 12.1.1.2
ip route 0.0.0.0 0.0.0.0 12.1.1.1
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 172.16.0.0 0.0.255.255

line vty 0 4
login local

R3配置
接口配置:
interface Loopback0
ip address 192.168.1.81 255.255.255.240
!
interface Ethernet0/0
ip address 192.168.1.2 255.255.255.252
ip summary-address rip 192.168.1.64 255.255.255.224
!
interface Ethernet0/1
ip address 192.168.1.5 255.255.255.252
ip summary-address rip 192.168.1.64 255.255.255.224
RIP配置:
router rip
version 2
network 192.168.1.0
no auto-summary
R4配置:
接口配置:
interface Loopback0
ip address 192.168.1.97 255.255.255.240
!
interface Loopback1
ip address 192.168.1.113 255.255.255.240
!
interface Ethernet0/0
ip address 192.168.1.6 255.255.255.252
ip summary-address rip 192.168.1.96 255.255.255.224
!
interface Ethernet0/1
ip address 192.168.1.9 255.255.255.252
ip summary-address rip 192.168.1.96 255.255.255.224

RIP配置:
router rip
version 2
network 192.168.1.0
no auto-summary
!
R5配置:
接口配置:
interface Loopback0
ip address 192.168.1.129 255.255.255.240
!
interface Loopback1
ip address 192.168.1.145 255.255.255.240
!
interface Ethernet0/0
ip address 192.168.1.10 255.255.255.252
ip summary-address rip 192.168.1.128 255.255.255.224
!
interface Ethernet0/1
ip address 192.168.1.13 255.255.255.252
ip summary-address rip 192.168.1.128 255.255.255.224

RIP配置:
router rip
version 2
network 192.168.1.0
no auto-summary

R6配置:
接口配置:
interface Loopback0
ip address 192.168.1.161 255.255.255.240
!
interface Loopback1
ip address 192.168.1.177 255.255.255.240
!
interface Ethernet0/0
ip address 192.168.1.14 255.255.255.252
ip summary-address rip 192.168.1.160 255.255.255.224
!
interface Ethernet0/1
ip address 192.168.1.21 255.255.255.252
ip rip send version 2
ip summary-address rip 192.168.1.0 255.255.255.0
!
interface Ethernet0/2
ip address 192.168.1.17 255.255.255.252
ip summary-address rip 192.168.1.160 255.255.255.224

RIP配置:
router rip
version 2
offset-list 1 in 3 Ethernet0/0
network 192.168.1.0
no auto-summary
access-list 1 permit 192.168.1.128 0.0.0.31
!

R7配置
接口配置:
interface Loopback0
ip address 172.16.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.1.22 255.255.255.252
ip rip send version 1 2
ip rip receive version 2
!
interface Ethernet0/1
ip address 172.16.3.1 255.255.255.0 secondary
ip address 78.1.1.1 255.255.255.0

RIP配置:
router rip
version 1
network 78.0.0.0
network 172.16.0.0
network 192.168.1.0
!

R8配置:
接口配置:

interface Loopback0
ip address 172.16.2.1 255.255.255.255
!
interface Ethernet0/0
ip address 172.16.3.2 255.255.255.0 secondary
ip address 78.1.1.2 255.255.255.0

RIP配置:
router rip
version 1
network 78.0.0.0
network 172.16.0.0

line vty 0 4
login local

以上就是我对RIP的简单总结。。感谢大家的浏览。。
如有不足的地方请多多指正。。我也是一个在追求网络知识道路上的新手。谢谢~

RIP总结及案例应用分析配置

标签:网络协议   路由交换   RIP   案例分析   

原文:http://blog.51cto.com/13046929/2086267

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号