首页 > 其他 > 详细

CF47A Triangular numbers

时间:2018-02-11 16:41:24      阅读:172      评论:0      收藏:0      [点我收藏+]

题意翻译

给定一个数n,问你是否存在一个整数i,满足i*(i+1)/2=n。

若存在,输出"YES",否则输出"NO".

1<=n<=500

Translated by @稀神探女

题目描述

A triangular number is the number of dots in an equilateral triangle uniformly filled with dots. For example, three dots can be arranged in a triangle; thus three is a triangular number. The nn -th triangular number is the number of dots in a triangle with nndots on a side. 技术分享图片. You can learn more about these numbers from Wikipedia (http://en.wikipedia.org/wiki/Triangular\_number).

Your task is to find out if a given integer is a triangular number.

输入输出格式

输入格式:

 

The first line contains the single number nn ( 1<=n<=5001<=n<=500 ) — the given integer.

 

输出格式:

 

If the given integer is a triangular number output YES, otherwise output NO.

 

输入输出样例

输入样例#1: 复制
1
输出样例#1: 复制
YES
输入样例#2: 复制
2
输出样例#2: 复制
NO
输入样例#3: 复制
3
输出样例#3: 复制
YES

技术分享图片

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        if(i*i+i==2*n){
            cout<<"YES";
            return 0;
        }
    cout<<"NO";
}

 

CF47A Triangular numbers

原文:https://www.cnblogs.com/cangT-Tlan/p/8442541.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!