首页 > 其他 > 详细

关于VLAN,Trunk,Hybird 配置思路

时间:2018-01-22 22:46:36      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:all   可选   属于   移除   psu   fault   公有   如何   查看   

VLAN配置思路:
1、创建vlan
sw1(config)#vlan 12
sw1(config-vlan)#name CAIWU
2、配置端口模式
sw1(config)#interface fas0/1 | fas0/2
sw1(config-if)#no shutdown
sw1(config-if)#switchport mode access
3、配置端口属于的vlan
sw1(config)#interface fas0/1 | fas0/2
sw1(config-if)#switchport access vlan 12
4、验证与测试
PC-1: 192.168.12.1 255.255.255.0
PC-2: 192.168.12.2 255.255.255.0
PC-1: ping 192.168.12.2

同样的操作步骤,完成 VLAN 34 的配置与主机之间的连通性测试;

删除VLAN:
1、将 VLAN 中的成员端口移除掉;
interface fas0/1
no switchport access vlan 12
2、删除 vlan ;
no vlan 12
3、验证(实际工作中 - 验证并保存配置)


华为交换机配置 VLAN :
1、创建VLAN
[sw1]vlan 10 //创建一个VLAN,并进入 VLAN 10 ;
[sw1-vlan10]description AAA // 为vlan配置一个名字;
2、配置端口模式
[sw1]interface gi0/0/1
[sw1-gi0/0/1]port link-type access //指定端口为access模式
3、将端口放入指定的 VLAN
[sw1]interface gi0/0/1
[sw1-gi0/0/1]port default vlan 10 //将端口放入vlan10
4、验证、测试、保存
[sw1]display vlan
PC-1 :
192.168.10.1 255.255.255.0
PC-2 :
192.168.10.2 255.255.255.0
删除 VLAN :
[sw1]undo vlan 10 //删除以后,成员端口会自动的回归到vlan1;
批量创建/删除 VLAN :
[sw1]vlan batch 10 20 30 40 50// 创建vlan 10,20,30,40,50;
[sw1]vlan batch 10 to 20 // 创建vlan 10,11,12,.....,20;
[sw1]undo vlan batch 10 to 20 // 批量删除10,11,12,....,20;


Trunk:
为了能够在同一个链路上同时传输多个 VLAN 的数据,
必须将链路的模式配置为 trunk 模式。

该类型的链路上的数据,是需要携带 vlan 标签的;
该链路为数据打标签的方式,分为两种:
      1、ISL  : inter-switch link ,交换机之间的链路协议,
                 思科的私有协议;现在很多交换机已经不支持了;
                 标签总长度为30个字节,
                 其中ISL头部是26个字节,ISL尾部是4个字节;

      2、802.1q :是公有标准,任何厂家的设备都支持使用该协议
                  为2层数据打标签。
                  标签长度为4个字节;
一般用来链接“交换机”设备。

Access:
这种类型的链路,同一时刻,只能属于一个 VLAN ;
传输的数据,是没有任何标签的。

一般用来连接“非交换机”设备!

配置 Trunk链路:(华为)
1、配置端口的链路类型
interface gi0/0/24
port link-type trunk
2、设置 Trunk 链路上允许通过的 VLAN
interface gi0/0/24
port trunk allow-pass vlan all
3、验证 、测试、保存
display port vlan


配置 Trunk链路:(思科)
1、配置链路的 trunk 封装协议(ISL或者 802.1q) [可选]
interface fas0/24
switchport trunk encapsulation dot1q | isl

 2、配置链路的模式为 trunk 
        interface fas0/24 
            switchport  mode  trunk 

 3、验证、测试与保存
        show interface trunk //查看思科交换机上的 trunk 链路;

华为交换机处理数据帧的过程:

1、当交换机收到的一个数据帧时,会为该数据帧打一个标签:
display port vlan
依靠的是该显示结果中的对应端口下的 PVID 参数;

2、当交换机将一个数据帧转发出去时候,查看的是以下对应表:
display vlan
在对应的 VLAN (即数据帧的入端口的PVID表示的VLAN)
后面的成员端口(这些端口,表示的是数据帧的出端口)
,同时要关注这些端口在发送出去数据时,是否携带标
签(TG/UT)

Hybird 配置过程:
1、创建VLAN 10
[sw]vlan 10
2、配置链接 PC 的链路类型为 hybrid
[sw]interface gi0/0/1
[sw-gi0/0/1]port link-type hybrid
3、配置每个端口上的 PVID 为 10 ;
[sw]interface gi0/0/1
[sw-gi0/0/1]port hybrid pvid vlan 10 [如何使用默认值,是否通]
4、配置每个端口上的不封装标签的 VLAN ;
[sw]interface gi0/0/1
[sw-gi0/0/1]port hybrid untagged vlan 10
5、配置 PC 的IP地址为: 192.168.10.x/24
6、验证、测试、保存
display port vlan // 查看 gi0/0/1 | 2 的 PVID 是否为 10 ;
display vlan // 查看 vlan 后面是否对应 gi0/0/1 | 2 ;
Ping 192.168.10.2
<sw>save


VLAN 5 互通:

PC1 --> PC3
sw1:

  interface gi0/0/1 
      port hybrid pvid vlan 5 // 确保该端口的入向数据打标签5;
  interface gi0/0/24 
      port hybrid tagged vlan 5 //确保交换机之间的链路转发数据
                                  出去时,携带标签5,为了让SW2
                                  识别;

sw2:
interface gi0/0/3
port hybrid untagged vlan 5 //SW2收到后携带标签5的数据后,
将其拆除,在 gi0/0/3 发出去;

PC3---> PC1
sw2:
interface gi0/0/3
port hybrid pvid vlan 5
interface gi0/0/24
port hybrid tagged vlan 5
sw1:
interface gi0/0/1
port hybrid untagged vlan 5

VLAN 10 互通:

PC2 --> PC4
sw1:

  interface gi0/0/2 
      port hybrid pvid vlan 10
  interface gi0/0/24 
      port hybrid tagged vlan 10 

sw2:
interface gi0/0/4
port hybrid untagged vlan 10

PC4---> PC2
sw2:
interface gi0/0/4
port hybrid pvid vlan 10
interface gi0/0/24
port hybrid tagged vlan 10
sw1:
interface gi0/0/2
port hybrid untagged vlan 10

关于VLAN,Trunk,Hybird 配置思路

标签:all   可选   属于   移除   psu   fault   公有   如何   查看   

原文:http://blog.51cto.com/13562283/2063830

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号