首页 > 其他 > 详细

CDOJ 145 Earthquake

时间:2017-12-04 22:47:39      阅读:195      评论:0      收藏:0      [点我收藏+]

After the big earthquake, a lot of roads have been destroyed, some towns are disconnected with each other.

In order to save the trapped as soon as possible, we need to try our best to rebuild the roads, and make sure all the towns will be reconnected(that is any villages is connected to the others with a clear route at least).

Unfortunately, we have only one team to rebuild the roads. Now,please tell us how long do you think these roads can be reconnected.

Input

The first line contains a number T denotes the number of test case.

For each test case,

In the first line, you will get two number N (1N1000) and M(1MN×N), denotes the number of towns and the number of roads.

The next M lines, each contains three number A,B,C, denotes there is a road between A and B that needed C (1×C×1000) minutes to rebuild.

Output

For each test case, you should output a line contains a number denotes the minimal time need to rebuild the roads so that all the towns are connected.

Sample input and output

Sample InputSample Output
2
3 3
1 2 3
2 3 3
3 1 7
3 3
1 2 3
2 3 3
3 1 1
6
4
#include <iostream>
#include <algorithm>
using namespace std;

int V,E,v[1005];
class edge {
public:
    int weight,from,to;
}e[1000005];

bool cmp(edge a,edge b) {
    return a.weight<b.weight;
}

int find(int x) {
    return (v[x]==x)?x:(v[x]=find(v[x]));
}

void MST() {
    int vnum=0,all_weight=0,x,y;
    for (int i=0; i<E&&vnum<V-1; i++) {
        x=find(e[i].from);
        y=find(e[i].to);
        if (x!=y) {
            v[x]=y;
            all_weight+=e[i].weight;
            vnum++;
        }
    }
    printf("%d\n",all_weight);
}

int main() {
    int t;
    scanf("%d",&t);
    while (t--) {
        scanf("%d%d",&V,&E);
        for (int i=0; i<V; i++)
            v[i]=i;
        for (int i=0; i<E; i++) {
            scanf("%d%d%d",&e[i].from,&e[i].to,&e[i].weight);
            e[i].from--;
            e[i].to--;
        }
        sort(e, e+E, cmp);
        MST();
    }
}

CDOJ 145 Earthquake

原文:http://www.cnblogs.com/soildom/p/7979192.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!