首页 > 其他 > 详细

pat1003

时间:2017-11-06 19:53:37      阅读:256      评论:0      收藏:0      [点我收藏+]

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

 

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

 

#include <iostream>
#include<stdio.h>
using namespace std;
int visit[10000];
int mp[1000][1000];
int v[1000];
int cnt,mx;
int mind;
int n,m,st,en;
void dfs(int p,int end,int dist ,int vu)
{

    if(p==end)
    {
        if(dist<mind)
        {
            cnt=1;
            mind=dist;
            mx=vu;
        }
        else if(dist==mind)
        {
            cnt++;
            if(mx<vu)
            {
                mx=vu;
            }
        }
        return;
    }
    int i;
    if(dist>mind)
        return;
    for(i=0;i<n;i++)
    {
        if(visit[i]==0&&mp[p][i]!=0x3f3f3f3f)
        {
            visit[i]=1;
            dfs(i,end,dist+mp[p][i],vu+v[i]);
            visit[i]=0;
        }
    }
}
int main()
{

    scanf("%d%d%d%d",&n,&m,&st,&en);
    cnt = 0;
   mind=0x3f3f3f3f;
    for(int i=0;i<n;++i)
        {
        visit[i] = 0;
        for(int j=0;j<n;++j)
        mp[i][j]=0x3f3f3f3f;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&v[i]);
        }
        int x,y,l;
        for(int i=0;i<m;i++)
        {
        cin>>x>>y>>l;
        if(mp[x][y]>l)
            mp[x][y]=mp[y][x]=l;
        }
        dfs(st,en,0,v[st]);
printf("%d %d\n",cnt,mx);
    return 0;
}

给你 4个数。。第一个数是 n个点。第2个是 m个距离。第3个数是起点,4是终点

下一行是n个数。表示每个点的值。

m行

输出 最小路的方案数。以及最大值

pat1003

原文:http://www.cnblogs.com/2014slx/p/7794727.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!