首页 > 系统服务 > 详细

Ubuntu 16.04安装Intel显卡驱动(解决Intel HD Graphics 630显卡驱动问题)

时间:2017-08-17 18:12:40      阅读:3387      评论:0      收藏:0      [点我收藏+]

标签:.debian   pri   algorithm   scu   form   info   recv   cau   lis   

一般Ubuntu都默认包含了Intel显卡的驱动,如果没有,那么先确定是不是显卡太高,比如I7第7代的CPU核显在Ubuntu 16.04中是没有的,导致画面会很卡,原因是Linux 4.4内核不包含Intel HD Graphics 630驱动,解决方法只能是在Ubuntu 16.04中升级Linux内核为4.7的。

以下是两种解决方法:

一、一般Intel显卡驱动安装及升级

下载intel-graphics-update-tool进行安装,中途会出现依赖问题:

wget https://download.01.org/gfx/ubuntu/16.04/main/pool/main/i/intel-graphics-update-tool/intel-graphics-update-tool_2.0.2_amd64.deb
sudo dpkg -i intel-graphics-update-tool_2.0.2_amd64.deb
sudo intel-graphics-update-tool 
sudo apt-get install -f
sudo intel-graphics-update-tool 
wget $(echo "https://download".01.org/gfx/RPM-GPG-GROUP-KEY-ilg) -O - | sudo apt-key add -
sudo apt-get update

然后运行sudo intel-graphics-update-tool会出现如下错误提示:

W:GPG error: https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease: The following signatures couldn‘t be verified because the public key is not available: NO_PUBKEY 56A3DEF863961D39, W:The repository ‘https://download.01.org/gfx/ubuntu/16.04/main xenial InRelease‘ is not signed., W:Data from such a repository can‘t be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:There is no public key available for the following key IDs:
56A3DEF863961D39  , E:Problem executing scripts APT::Update::Post-Invoke-Success ‘if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi‘, E:Sub-process returned an error code

解决方法是添加两个签名:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-4 -O - | sudo apt-key add -

然后运行sudo intel-graphics-update-tool会出现如下错误提示:

W:https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease: Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1), E:Problem executing scripts APT::Update::Post-Invoke-Success ‘if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi‘, E:Sub-process returned an error code

解决方法:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 09D6EF97BFB38E916EF060E756A3DEF863961D39
sudo apt-get update
sudo pkill -KILL appstreamcli
wget -P /tmp https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
sudo dpkg -i /tmp/appstream_0.9.4-1ubuntu1_amd64.deb /tmp/libappstream3_0.9.4-1ubuntu1_amd64.deb
sudo apt-get update

然后运行sudo intel-graphics-update-tool会出现如下错误提示:

Error running transaction: GDBus.Error:org.debian.apt.TransactionFailed: error-dep-resolution-failed: The following packages have unmet dependencies:

libgles1-mesa: Depends: libglapi-mesa (= 12.0.6-0ubuntu0.16.04.1) but 17.0.7-0ubuntu0.16.04.1 is to be installed

The following packages have unmet dependencies:

libgles1-mesa: Depends: libglapi-mesa (= 12.0.6-0ubuntu0.16.04.1) but 17.0.7-0ubuntu0.16.04.1 is to be installed

解决方法:

sudo add-apt-repository ppa:paulo-miguel-dias/pkppa && sudo apt-get update

然后运行sudo intel-graphics-update-tool后基本正常安装了。

但是以上方式即使全部安装之后都不能解决Intel HD Graphics 630显卡的驱动。

 

参考:

https://www.vivaolinux.com.br/topico/UbuntuBR/ERRO-NO-APT-GET-UPDATE-11

http://www.cnblogs.com/EasonJim/p/7343892.html

https://askubuntu.com/questions/943647/intel-graphic-installer-2-0-2-fails-on-fresh-ubuntu-16-04

https://01.org/linuxgraphics/forum/graphics-installer-discussions/new-ubuntu-16.04-packages-use-unknown-key-again?page=1

二、解决Intel HD Graphics 630显卡驱动问题

升级4.7的内核,步骤如下:

下载脚本:

https://software.intel.com/en-us/forums/opencl/topic/738108

使用:

mv install_OCL_driver.sh_.txt install_OCL_driver.sh
chmod 755 install_OCL_driver.sh
sudo su
./install_OCL_driver.sh install

完成后的提示信息:

...
Installation completed successfully.

Next steps:
1. Add OpenCL users to the video group: ‘sudo usermod -a -G video USERNAME‘
   e.g. if the user running OpenCL host applications is foo, run: sudo usermod -a -G video foo

2. If you have Intel Pentium J4000 or Intel Celeron J3000, you will need to add:
   i915.preliminary_hw_support=1
   to the 4.7 kernel command line, in order to enable OpenCL functionality for these platforms.

3. Reboot into the patched 4.7 kernel

HINT: to boot into the 4.7 kernel do the following:
      1) Hold the "shift" button during boot
      2) When the GRUB menu appears, select "Advanced options for Ubuntu"
      3) Select the Linux 4.7.0.intel.r5.0 kernel from the list

重启后即可。

 

离线文件:

链接: https://pan.baidu.com/s/1qXW2k5A 密码: 2rj2

Ubuntu 16.04安装Intel显卡驱动(解决Intel HD Graphics 630显卡驱动问题)

标签:.debian   pri   algorithm   scu   form   info   recv   cau   lis   

原文:http://www.cnblogs.com/EasonJim/p/7383131.html

(0)
(2)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号