首页 > 其他 > 详细

POJ 3096-Surprising Strings(set)

时间:2017-06-23 19:01:32      阅读:241      评论:0      收藏:0      [点我收藏+]
Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5940   Accepted: 3894

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
STL专题。想了一会还是决定用set吧,题意:给一个字符串,问它是不是 surprising 。surprising的定义是这种:
对于一个单词中的每一个字母来说,都有一个距离的概念,比方 ZGBG 第一个字母Z和第二个字母G的距离为0,第二个字母G和第三个字母B的距离为0。依次类推,所以说距离为0的两个字母有 ZG GB BG 这三个串都各不同样。然后求出距离为1的串 看看他们是不是有同样的。假设终于都没有同样的,那么这个单词就是surprising 否则就不是。

#include <iostream>
#include <cstdio>
#include <cctype>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <cstring>
using namespace std;
int main()
{
	string x;

	while(cin>>x&&x[0]!=‘*‘)
	{
		if(x.size()<=1)
	    {
		printf("%s is surprising.\n",x.c_str());
		continue;
	    }
		int len=x.size(),flag=1;
		for(int i=1;i<=len-1;i++)
		{
			int cnt=0;set <string> s;
			for(int j=0;j+i<len;j++)
			{
			  string a;char xx[5];
			  xx[0]=x[j];xx[1]=x[j+i];xx[2]=‘\0‘;
			  a.assign(xx);
			  //cout<<a<<endl;
			  s.insert(a);
			  cnt++;
			}
			if(s.size()!=cnt)
			{
				printf("%s is NOT surprising.\n",x.c_str());
				flag=0;
				break;
			}
		}
		if(flag)
			printf("%s is surprising.\n",x.c_str());
	}
	return 0;
}

POJ 3096-Surprising Strings(set)

原文:http://www.cnblogs.com/ljbguanli/p/7071244.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!