首页 > 其他 > 详细

TOJ-1309 Jugs

时间:2017-01-21 16:11:25      阅读:266      评论:0      收藏:0      [点我收藏+]
In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A
fill B
empty A
empty B
pour A B
pour B A
success

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca ≤ Cb and N ≤ Cb ≤1000 and that A and B are relatively prime to one another.

Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 4
5 7 3

Sample Output
fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success

Note: Special judge problem, you may get "Wrong Answer" when output in wrong format.



Source: South Central USA 1997; Northeastern Europe 2002 Western Subregion

 

acm最让人头痛的莫过于数论了,有时它比算法题更让你无从下手。

由题目知道,ca<cb且二者互质,n<cb。可知对自然数k,(k*ca%cb)是一个小于cb的数,那么我们可以改变k值来使(k*ca%cb)=n。

 

#include <stdio.h>

int main(){
    int ca,cb,n,a,b;
    while(~scanf("%d%d%d",&ca,&cb,&n)){
        a=0;b=0;//当前两个罐子都空
        while (b!=n){
            if(a==0){//a罐子空 ,装满 
                a=ca;
                printf("fill A\n");
            }
            b+=a;//将a倒入b 
            a=0;
            printf("pour A B\n");
            if(b>cb){//b满清空 
                a=b-cb;
                b=0;
                printf("empty B\n");
            }
        }
        printf("success\n");
    }
    return 0;
}

 

TOJ-1309 Jugs

原文:http://www.cnblogs.com/shenchuguimo/p/6337114.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!