首页 > 其他 > 详细

hdu2647 N!Again

时间:2016-08-08 17:39:30      阅读:251      评论:0      收藏:0      [点我收藏+]

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4781    Accepted Submission(s): 2527


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven‘s finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 


Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 


Output
For each case, output N! mod 2009
 


Sample Input
4 5
 


Sample Output
24 120
 


Author
WhereIsHeroFrom
 


Source
 


Recommend
lcy   |   We have carefully selected several similar problems for you:  2672 2668 2673 2669 2671 
 


Statistic | Submit | Discuss | Note

看到n的范围  脑子里就知道是规律。。。

其实把结果输出一下就看到了。如果某个值正好整除2009  那么 后面的都是0了

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sca=new Scanner(System.in);
		while(sca.hasNext()){
			int x=sca.nextInt();
			if(x>41){
				System.out.println(0);
				continue;
			}
			BigInteger res=BigInteger.ONE;
			for(int i=2;i<=x;i++){
				res=res.multiply(BigInteger.valueOf(i));
				res=res.mod(BigInteger.valueOf(2009));
			}
			System.out.println(res);
		}
	}

}



hdu2647 N!Again

原文:http://blog.csdn.net/su20145104009/article/details/52153883

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!