首页 > 其他 > 详细

杭电 4165 Pills

时间:2014-05-07 06:33:20      阅读:463      评论:0      收藏:0      [点我收藏+]

Pills

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s):    Accepted Submission(s):


Problem Description
Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?
 

Input
The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.
 

Output
For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.
 

Sample Input
6 1 4 2 3 30 0
 

Sample Output
132 1 14 2 5 3814986502092304
卡特兰数列!!!!!1

AC代码如下:

#include<stdio.h>

int main()
{
    __int64 f[31],n,i;
    for(f[1]=1,i=2;i<=30;i++)
        f[i]=(f[i-1]*(4*i-2))/(i+1);
    while(~scanf("%I64d",&n)&&n)
    {
        printf("%I64d\n",f[n]);
    }

    return 0;
}



杭电 4165 Pills,布布扣,bubuko.com

杭电 4165 Pills

原文:http://blog.csdn.net/hanhai768/article/details/25078441

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!