首页 > 其他 > 详细

UVA OJ-11095 Maximum Product(暴力求解法)

时间:2016-04-30 18:12:15      阅读:175      评论:0      收藏:0      [点我收藏+]

 

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.
题目大意:最大连续子序列乘积
#include<iostream>
using namespace std;
int main() {
  int n, a[20], count = 1;
  while (cin >> n) {
    for (int i = 0; i < n; i++)
      cin >> a[i];
    long long max = 0;//如果最大乘积不是正数,输出0 
    for (int i = 0; i < n; i++) {//枚举起点 
      long long sum = 1;
      for (int j = i; j < n; j++) {//枚举终点 
        sum *= a[j];
        if (sum > max)
          max = sum;
      } 
    }  
    cout << "Case #" << count++ << ": The maximum product is " << max << "." << endl;
    cout << endl;
  }
} 

  

UVA OJ-11095 Maximum Product(暴力求解法)

原文:http://www.cnblogs.com/Rhett-Q/p/5448991.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!