Play the Dice
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 708 Accepted Submission(s): 251
Special Judge
Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai
yuan. What‘s more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling
chance. Now you need to calculate the expectations of money that we get after playing the game once.
Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers ai(0<=ai<200)
The second line is an integer m (0<=m<=n), following with m integers bi(1<=bi<=n), which are the numbers of the special sides to get another more chance.
Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
Sample Input
6 1 2 3 4 5 6
0
4 0 0 0 0
1 3
Sample Output
Source
给你一个有n个面的筛子,每个面都有一个值,另外有m面如果选中了,可以在投一次,问你期望是多少。
如果没有“m面选中可以在投一次”这一条件,那么期望就是n个面的值之和除以n,记为p=sum/n。
如果有了这个条件,那么只投一次的话,期望就是sum;如果投了两次的话就是p*(m/n);如果投了三次的话就是p*(m/n)^2,无限次就是p*(1+q+q^2+q^3+..+q^k+...)(q=m/n,p=sum/n)
根据等比数列以及无限化简得:sum/(n-m)。
//46MS 224K
#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d",&n)!=EOF)
{
double a,sum=0;
for(int i=1;i<=n;i++)
{
scanf("%lf",&a);
sum+=a;
}
scanf("%d",&m);
for(int i=1;i<=m;i++)
scanf("%lf",&a);
if(sum==0){printf("0.00\n");continue;}
if(m==n){printf("inf\n");continue;}
printf("%.2lf\n",sum/(n-m));
}
return 0;
}
HDU 4586 Play the Dice 概率期望,布布扣,bubuko.com
HDU 4586 Play the Dice 概率期望
原文:http://blog.csdn.net/crescent__moon/article/details/24270475