首页 > Web开发 > 详细

zabbix 安装提示PHP gettext off Warning

时间:2015-12-07 00:52:07      阅读:1809      评论:0      收藏:0      [点我收藏+]

标签:动态   如何   

这个错误有两种可能

  1. 你编译安装的是时候没有指定这个库 --with-gettext

  2. 你安装了系统没有找到

如何解决

  1. 重新编译加上 --with-gettext

  2. 编译php动态扩展库

  第一种情况我们就不提了

主要说第二种

首先进入php 源码包

进入 ext 目录下我们会发现有个 gettext 模块

执行如下命令

 /application/php5.3.27/bin/phpize   #   /application/php5.3.27/  php 安装路径 根据自己的安装路径而定

./configure --with-php-config=/application/php5.3.27/bin/php-config

make && make install

/application/php5.3.27/lib/php.ini    #根据自己系统安装路径而定

在php.ini里添加上gettext.so

extension = "gettext.so"

重启php就ok了

如果你安装了这个库但是没有,你可以编辑php.ini 把路径加进去。

   #根据自己系统安装路径而定

在php.ini里添加上gettext.so

extension = "gettext.so"

给他加进去。

本文出自 “tomxia” 博客,请务必保留此出处http://tomxia.blog.51cto.com/2842856/1720047

zabbix 安装提示PHP gettext off Warning

标签:动态   如何   

原文:http://tomxia.blog.51cto.com/2842856/1720047

(1)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号