首页 > 其他 > 详细

集训第六周 数学概念与方法 概率 数论 最大公约数 G题

时间:2015-08-20 09:08:05      阅读:170      评论:0      收藏:0      [点我收藏+]

Description

There is a hill with n holes around. The holes are signed from 0 to n-1. 

技术分享


A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
 

Sample Input

2
1 2
2 2
 

Sample Output

NO
YES
 
 
给出两个数,如果它们的公约数大于1就输出YES,否则输出NO
 
技术分享
#include"iostream"
using namespace std;

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

int main()
{
    int T,m,n;
    cin>>T;
    while(T--)
    {
        cin>>m>>n;
        cout<<((gcd(m,n)>1)?"YES":"NO")<<endl;
    }
    return 0;
}
View Code

 

集训第六周 数学概念与方法 概率 数论 最大公约数 G题

原文:http://www.cnblogs.com/zsyacm666666/p/4744033.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!